読者です 読者をやめる 読者になる 読者になる

Ruby 2.0.0-p0 で gem install rdoc した件

rbenvでインストールしたRuby 2.0.0-p0環境で、gem install rdoc すると以下のようなメッセージがでる。

rdoc's executable "rdoc" conflicts with /Users/yohei/.rbenv/versions/2.0.0-p0/bin/rdoc
Overwrite the executable? [yN]

Rubyにはじめから入っているrdocコマンドが gem からインストールされるrdocコマンドに差分があるためこのようなメッセージが表示されるようだ。 gem版のrdocコマンドはgemにバンドルされているrdocコマンドを呼び出すよくあるRubyGemsのstubになっている。

gem版を利用するのであれば、特に問題なさそうなので、とりあえず yと答えておいて良いと思う。

参考:https://bugs.ruby-lang.org/issues/5060